logo
logo

Included libraries

The following libraries are included by default in every external page component script:

  • CKEditor 4

    ScriptsVersion
    ckeditor4/ckeditor.js4.12.1
  • CKEditor 5

    ScriptsVersion
    ckeditor/ckeditor.js11.2.0
  • Polyfills

    ScriptsVersion
    Array.find.js1.2.2
    classList.js1.2.2
  • Jquery

    ScriptsVersion
    jquery-3.2.1.js3.2.1
    jquery-extras.js3.2.1
    jquery-ui.js1.12.1
    jquery.ui.touch-punch.js0.2.3
    jquery.validate.js1.17.0
    jquery.validate.unobtrusive.js1.17.0
    jquery.barrating.js1.2.2
  • Lazyload

    ScriptsVersion
    lazyload.min.js8.17.0
  • bootstrap

    ScriptsVersion
    bootstrap.bundle.js4.1.3
    bootstrap-datetimepicker.js4.17.47
    bootstrap-select.js1.13.2
    bootstrap-multiselect.js0.9.12
    bootstrap-tokenfield.js0.12.1
  • mousetrap

    ScriptsVersion
    mousetrap.js1.6.1
  • toastr

    ScriptsVersion
    toastr.js2.1.1
  • moment

    ScriptsVersion
    moment-with-locales.js2.20.1
  • underscore

    ScriptsVersion
    underscore.js1.9.1
  • Knockout

    ScriptsVersion
    knockout-3.4.2.js3.4.2
    knockout-else.js1.0.12
    knockout.punches.js0.5.1
    knockout-es5-clean.js0.4.6
    knockout-bootstrap.js0.2.0
    knockout-sortable.js1.1.0
    knockout-selection-bindings.js0.10.0
    knockout-extra-extenders.js3.5.0
    knockout-bootstrap-select.js3.5.0
    knockout-modal.js2.0.0
    knockout-nestable.js3.5.0
    knockout-templateEngine.js0.3.0
    knockout-projections-1.0.29.js1.1.0
    knockout-dhtmlx.js4.2.0
    knockout-pivottable.js3.5.0
    knockout-validation.js2.0.3
    knockout-extra-validators.js2.0.3
    knockout-storyboard.js3.5.0
    knockout-dirty.js1.0.0
    knockout-speedtest.js4.5.4
    knockout-flow-editor.js3.5.0
    knockout-handsontable.js1.0.0
    knockout-augmented-reality.js1.0.0
    knockout-ckeditor4.jsN/A
  • Nestable

    ScriptsVersion
    nestable.js1.0
  • Mediaelement

    ScriptsVersion
    mediaelement-and-player.js4.2.5
    mediaelement-extensions.js4.2.5
  • jsoneditor

    ScriptsVersion
    jsoneditor-minimalist.js5.13.2
  • history

    ScriptsVersion
    history.js1.8.0
    history.adapter.jquery.js1.8.0
  • slick

    ScriptsVersion
    slick.js1.8.0
  • twitter

    ScriptsVersion
    typeahead.js0.11.1
  • clipboardjs

    ScriptsVersion
    clipboard.js2.0.4
  • dhtmlx

    ScriptsVersion
    dhtmlxgantt.js4.2.0 Professional
    dhtmlxscheduler.js4.4.9 Professional
  • jsdiff

    ScriptsVersion
    jsdiff.js3.4.0
  • linkify

    ScriptsVersion
    linkify.js2.1.5
    linkify-html.js2.1.5
  • signalR

    ScriptsVersion
    signalR.js2.2.2
  • mediatorjs

    ScriptsVersion
    mediator.js0.9.9
  • IWC

    ScriptsVersion
    iwc-all.js1.0.0
  • fine-uploader

    ScriptsVersion
    all.fine-uploader.js5.16.0
  • pivot

    ScriptsVersion
    pivot.js2.20.0
    highchart_renderers.js5.0.0
  • dragSelect

    ScriptsVersion
    DragSelect.js1.7.21
  • monaco-editor

    ScriptsVersion
    loader.js0.15.3
    editor.main.nls.js0.15.3
    editor.main.js0.15.3
  • jsplumb

    ScriptsVersion
    jsplumbtoolkit.js2.8.0
  • handsontable

    ScriptsVersion
    handsontable.full.min.js6.2.2
    tablerelationeditor.js6.2.2
  • chosen

    ScriptsVersion
    chosen.jquery.min.js1.8.7
    handsontable-chosen-editor.js1.8.7
  • three

    ScriptsVersion
    three.js0.96.0
    Detector.js0.96.0
    OrbitControls.js0.96.0
    OBJLoader.js0.96.0
    SL_MTL_Loader.js0.96.0
    arucomarker.js0.96.0
    webcam.js0.96.0
  • d3

    ScriptsVersion
    d3.js3.4.9
    d3-tip.js3.4.9
  • aruco

    ScriptsVersion
    aruco.js1.0.0
    svd.js1.0.0
  • highcharts

    ScriptsVersion
    highcharts.src.js6.2.0
    highcharts-exporting.js6.2.0
    highcharts.extend.js6.2.0
    highcharts.theme.js6.2.0
    highcharts-treemap.js6.2.0

Can we improve this article ? Provide feedback